Skip to content

chore: require Python 3.11+ and upgrade filelock to 4.2.4 - #9581

Merged
koenvanderveen merged 1 commit into
devfrom
koen/drop-python-310
Oct 26, 2026
Merged

koenvanderveen merged 1 commit into
devfrom
koen/drop-python-310

Conversation

@koenvanderveen

Copy link
Copy Markdown
Collaborator

Why

Dependabot alert #230 (high, GHSA-v4x8-3wr5-3wq8) is in filelock, which comes in through virtualenv. The fix is in filelock 4.2.1+, but filelock 4.x needs Python 3.11+, so with requires-python = ">=3.10" uv stayed on the vulnerable 3.32.x.

Changes

  • requires-python bumped to >=3.11 in the root and all packages/* pyprojects; removed the 3.10 classifier; updated CONTRIBUTING.
  • uv lock --upgrade-package filelock: filelock 3.32.2 → 4.2.4. The other lock changes only drop packages/forks that existed for Python 3.10.
  • syft_restrict/verifier.py: ast.TryStar / ast.Match used directly now that both always exist.

This also fixes the two low filelock alerts (#232, #233).

Tests

  • just test-unit-fast: 578 passed
  • packages/syft-restrict: 233 passed
  • pre-commit run --all-files: clean

filelock 4.2.1+ fixes GHSA-v4x8-3wr5-3wq8 (Dependabot alert #230) but
requires Python >=3.11, which kept uv on the vulnerable 3.32.x line.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant