Skip to content

chore(deps): update dependency body-parser to v2.4.0 [security] - autoclosed - #563

Closed
renovate[bot] wants to merge 1 commit into
mainfrom
renovate/npm-body-parser-vulnerability
Closed

renovate[bot] wants to merge 1 commit into
mainfrom
renovate/npm-body-parser-vulnerability

Conversation

@renovate

@renovate renovate Bot commented Oct 25, 2026

Copy link
Copy Markdown
Contributor

This PR contains the following updates:

Package Change Age Adoption Passing Confidence
body-parser 2.3.0 → 2.4.0 age adoption passing confidence

body-parser vulnerable to Denial of Service via trailing bytes after a compressed request body

CVE-2026-111181 / GHSA-27r3-jxmh-p828

More information

Details

Impact

A single request can crash any application using body-parser with default options. When a request carries a Content-Encoding (for example gzip), body-parser pipes it into a decompression stream and, after reading the body, leaves that stream piped with no error listener. A payload of one valid compressed frame followed by trailing bytes decodes and the application responds normally, but the trailing bytes then reach the already-finished decoder, which emits an error that is re-thrown as an uncaught exception and terminates the process. No authentication or matching route is required, since parsing runs before routing.

Patches

Fixed in body-parser 2.4.0 and 1.20.9. Upgrade to one of these versions.

Workarounds

Pass inflate: false to the body-parser middleware if the application does not need to accept compressed request bodies. This rejects encoded requests before any decompression stream is created.

Severity

  • CVSS Score: 7.5 / 10 (High)
  • Vector String: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References

This data is provided by the GitHub Advisory Database (CC-BY 4.0).


Release Notes

expressjs/body-parser (body-parser)

v2.4.0

Compare Source

=====

  • Security fix for GHSA-27r3-jxmh-p828 (CVE-2026-111181)
  • feat: add zstd content-encoding support (#​586)
    • Requires Node.js ^22.15.0 or >=23.8.0; older versions keep returning 415 for zstd encoded bodies
  • fix: avoid mutating the parser options and the request object while reading the body (#​742, #​750)
  • perf(json): avoid first-char regex for direct JSON bodies (#​744)
  • deps:
    • content-type@^2.1.0
    • iconv-lite^0.7.3
    • qs@^6.16.1

Configuration

📅 Schedule: (UTC)

  • Branch creation
    • At any time (no schedule defined)
  • Automerge
    • At any time (no schedule defined)

🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.

♻ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 Ignore: Close this PR and you won't be reminded about this update again.


  • If you want to rebase/retry this PR, check this box

This PR was generated by Mend Renovate. View the repository job log.

@renovate
renovate Bot force-pushed the renovate/npm-body-parser-vulnerability branch from c33edd5 to cc19d6f Compare October 25, 2026 13:09
@renovate renovate Bot changed the title chore(deps): update dependency body-parser to v2.4.0 [security] chore(deps): update dependency body-parser to v2.4.0 [security] - autoclosed Oct 25, 2026
@renovate renovate Bot closed this Oct 25, 2026
@renovate
renovate Bot deleted the renovate/npm-body-parser-vulnerability branch October 25, 2026 13:12
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

0 participants